13 lines
300 B
Nix
Executable file
13 lines
300 B
Nix
Executable file
{lib, ...}: {
|
|
services.openssh = {
|
|
enable = true;
|
|
settings = {
|
|
KbdInteractiveAuthentication = false;
|
|
PermitRootLogin = "no";
|
|
PasswordAuthentication = false;
|
|
UseDns = true;
|
|
X11Forwarding = false;
|
|
};
|
|
};
|
|
systemd.services.sshd.wantedBy = lib.mkForce [];
|
|
}
|